1°C
завтра: 1°C
Погода в Перми
1°C
вечером1°C
ночью0°C
завтра1°C
Подробно
 64,35
+0.0907
Курс USD ЦБ РФна 17 октября
64,3455
+0.0907
 71,05
+0.2030
Курс EUR ЦБ РФна 17 октября
71,0503
+0.2030
PRM.Форум /Компьютеры Интернет Связь / Программирование /

Добавление нового элемента справочника

  • Подскажите как можно добавить новый элемент в определенную группу в справочнике???
    Если возможно то напишите плз правильный код
    Заранее благодарен!!!

    Процедура ВводСотрудника()
    Спр = СоздатьОбъект("Справочник.Сотрудники");
    // добавляем новый элемент справочника
    Спр.Новый();
    // Определяем реквизиты нового элемента справочника
    Спр.Наименование = ФИО;
    Спр.Код = ТН;
    Спр.Оклад = Оклад;
    Спр.Аванс = Аванс;
    // ...
    // Записываем новый элемент справочника
    Спр.Записать();
    КонецПроцедуры

  • RTFM, типа вот этой:

    "Новый
    Добавить новый элемент справочника.

    Синтаксис:

    Новый()

    Англоязычный синоним:

    New

    Описание:

    Метод Новый инициализирует создание нового элемента справочника. Соб­ственно запись нового элемента происходит при вызове метода Записать. По­сле инициализации создания нового элемента справочника, как правило, про­изводится заполнение его реквизитов с последующим вызовом метода Записать.

    Данный метод может использоваться только для объектов, созданных функцией СоздатьОбъект.

    Пример:

    Процедура ВводСотрудника()

    Спр = СоздатьОбъект("Справочник.Сотрудники");

    // добавляем новый элемент справочника

    Спр.Новый();

    // Определяем реквизиты нового элемента справочника

    Спр.Наименование = ФИО;

    Спр.Код = ТН;

    Спр.Оклад = Оклад;

    Спр.Аванс = Аванс;

    // ...

    // Записываем новый элемент справочника

    Спр.Записать();

    КонецПроцедуры
    *******************************************************
    НоваяГруппа
    Добавить новую группу справочника.

    Синтаксис:

    НоваяГруппа()

    Англоязычный синоним:

    NewGroup

    Описание:

    Метод НоваяГруппа добавляет пустую запись новой группы в справочник. Данный метод может использоваться только для объектов, созданных функци­ей СоздатьОбъект.

    Пример:

    Процедура ВводГруппыСотрудников()

    Спр = СоздатьОбъект("Справочник.Сотрудники");

    // добавляем новую группу справочника

    Спр.НоваяГруппа();

    // Определяем реквизиты новой группы справочника

    Спр.Наименование = "Расчетчик3";

    Спр.Код = 3;

    // Записываем на диск

    Спр.Записать();

    КонецПроцедуры"

  • Вы меня неправильно поняли... как создать новый элемент и как создать новую группу, я знаю...
    То что Вы написали присутствует в справке.
    Вопрос был немного другой... "как добавить новый элемент в заранее созданную группу?"
    Например есть две группы "Поставщики" и "Покупатели", мне нужно некую фирму добавить в группу "Поставщики"...

  • У каждого элемента справочника есть атрибут Родитель - это значение группы к которой принадлежит элемент, присвой этому аттрибуту то значение которое тебе нужно и все.
    Да, группа должна иметь тип значения Справочник.Х если ты создаешь новый элемент справочника Х

    Цензура

Записей на странице:

Перейти в форум

Модератор: