Мобильная версия форумов
Открыть
 0°C
завтра: −6°C
Погода в Перми
0°C
ночью−2°C
утром−5°C
завтра−6°C
Подробно
 65,54
−0.3167
Курс USD ЦБ РФна 22 февраля
65,5401
−0.3167
 74,30
−0.3853
Курс EUR ЦБ РФна 22 февраля
74,2963
−0.3853
  • activist

    Сообщений: 381

    Скажу сразу, у меня Win Me :ухмылка:. Установил апачи с родного сайта, я себе его уже устанавливал раньше, поэтому проблем не возникло. Радостно проверил http://localhost Открылась апачинская страничка с поздравлениями, и благодарностями за использование.:хехе:Но в той версии апачи, кое что было подругому чем раньше, и я решил уж лучше установить всё снова, но старую проверенную апачи, по инструкциям найденным в интернете! Я удалил новую апачи и здесь вся радость закончилась! :безум:

    Первый глюк возник после того как я по советам в автоэкзеке.бат прописал строчку
    subst Z: C:\INTERNET
    которая должна была бы создать новый диск, данные которого хронились бы в папке Internet” на диске С. При загрузке автоэкзека все заработало, но стоило перегрузить комп, как диск Z исчез, вместе с той строчкой прописаной в автоэкзэке.

    Ну ладно, думаю, обойдусь. Потом, не установив ещё старую апачи, я решил проверить Http://localhost и что я вижу: файлы из папки c:/Downloads (туда качаю файлы из инета) причем они расположены в виде списка сверху вниз, а справа от названий цисло, их размер в байтах. Что самое странное, я подобных страниц, скриптов не писал на своем компе, и нигде их копии не держал на своем НDD.

    Далее, думаю, установлю апачи и глюк исчезнет – установил, глюк не исчез
    0) Удалил начисто Апачи, и все прилагающиеся файлы – не помогло
    1) Удалил папку Downloads, в Http://localhost теперь грузится пустое окно (но ведь должна быть ошибка о невозможности открытия файла, я ведь удалил апачи)
    2) Удалил все файлы которые устанавливал с апачи из C:/windows,
    3) пролазил в реестре в поисках localhost, ничего дельного не обнаружил,
    4)переустановил поверх винду, как предполагал, ничего не изменилось
    5) перерыл свой НДД, тоже ничего дельного не нашел.

    Люди кто сталкивался с такой проблемой? Как сделать, чтоб всё было попрежнему?

    Я не хочу стирать папку C\windows или даже форматировать ЖД. Как всё вернуть обратно!??!?!?

  • Анонимный пользователь
    ну уж кто-то наверняка висит на 80 порту. Раз это не апач, наверное это IIS

  • experienced

    Сообщений: 792

    Есть такая вещь - AppServ. Поищи, может понравится. Ставит все кроме перла сама. По крайней мере я уже второй год пользую, и геммороя с установкой сервера не испытываю. Хотя, если надо, и ручками работать приходится.

    ***

  • Анонимный пользователь
    Во-первых, строчку subst Z: C:\INTERNET лучше отдельным БАТфайлом в Автозагрузку кидать.
    Во-вторых, я могу намылить ТХТфайл с подробными инструкциями.

    А проблема может заключаться в файле "hosts"
    Я не помню где он лежит в Win9x/Me, но где-то в Windows либо ниже.

    Глюки могут быть "от фонаря", а убираются они сменой localhost на имя типа myhost и сменой IP 127.0.0.1 на какой-нибудь 127.0.0.5 (и соответственно настройки и httpd.conf)

    У меня все так и стоит на WinXP. Нормально стояло и год назад на Pentium-100 Win95 и нисколько не тормозило! Так же стоит PHP и Perl. Все работает.

  • Олегус

    Анонимный пользователь

    Файла hosts лежит в папке ..\Windows\system32\drivers\etc\ Для Вин2к соответственно в ..\WINNT\system32\drivers\etc\

  • activist

    Сообщений: 381

    Спасибо за ответы. Но проблема до сих пор не решена.
    Теперь по порядку:

    Яромир
    Я согласен, что кто то висит. Но я не устанавливал до этого других серверов, и IIS у меня нет, в моём WIN ME его не встраивают, по крайней мере у меня.

    Я даже сейчас склоняюсь к мысли, что это кто-то решил мне навредить. Обычно я считаю что если человек говорит, что во всем виноваты вирусы, то он чайник, но теперь именно я в таком положении.

    all
    AppServer делу не поможет, хотя я его скачал, но это тот же апачи, и вместо того чтоб на localhoste загружалась апачинская страничка, там не понятнокем сделанная страничка отображающая список скаченных файлов из папки downloads а справа подписано точный размер занимаемого файла.

    Солнчик
    Спасибо, так и попробую, когда отформатирую диск. Сейчас у меня, нет никакого сервера, вернее я так считаю, но глюк не исчезает. Файл hosts я нашёл, очистил, ничего не изменилось

    Олегус
    У меня Win Me файл находится только в папке C:\Windows\


    Вобщем выход один - ФОРМАТ диска :спок:

  • Анонимный пользователь
    скачай и поставь AtGuard, постучись на 80 порт, а AtGuard тебе скажет, чо за приложение на нем (80 порту) висит. Через зад, зато должно сработать.

    другой personal firewall тоже сойдет.

  • Анонимный пользователь
    Первым делом - telnet localhost 80 - если соединение установилось, 2 раза нажми на ввод.. там будет ответ сервера - посмотри, кто это... возможно апач криво удалился..

  • guru

    Сообщений: 3810

    1.Снести грамотно апач, и потом поставить его заново после ребута.
    2. Сразу же просмотреть внимательнейшим образом httpd.conf и настроить на свои папки, там нафиг не надо subst всякие делать.

    Работник цифродробительного цеха.

  • Анонимный пользователь
    1. Скорее всего, Apache был удален криво, хотя существует вероятность того, что тебе поставили что-то типа HTML-KeyLogger - клав. шпион с показом результатов по HTTP =) после аутентификации - отсюда пустой экран вместо ошибки. Сделай 'netstat -a' - увидишь все соединения. BTW, AtGuard для этого ставить НЕ НАДО, если кто не знал. В FAR'e есть такая фишка - просмотр//удаление процессов. WinKiller - то же самое, только показывает ЛЮБОЙ процесс, будь он даже системным.
    2. WinME проверяет autoexec.bat на левые записи, после чего последние уносятся в бескрайние просторы галактики. Используй другой метод загрузки. Нафига тебе subst??? Apache можно спокойно заставить обрабатывать папки и файлы с пробелами и прочей мишурой.
    3. Можешь поставить старую [старший разряд

Записей на странице:

Перейти в форум

Модератор: