0°C
завтра: 4°C
Погода в Перми
0°C
ночью2°C
утром3°C
завтра4°C
Подробно
 63,95
−0.0602
Курс USD ЦБ РФна 19 октября
63,9542
−0.0602
 71,13
+0.2276
Курс EUR ЦБ РФна 19 октября
71,1299
+0.2276
PRM.Форум /Компьютеры Интернет Связь / Программирование /

1с8.0. УПП. Как формируются проводки?

  • В частности интересует формирование проводок документом "ОтчетККМОПродажах". Всю обработку проведения пошагово прошел, ничего кроме "Сторно выручки" не могу найти. Но ведь откуда-то они берутся...

  • Чтот я тебя не понимаю.. Смотрим процедуру ОбработкаПроведения, видим:

    Если Не Отказ Тогда
    ДвиженияПоРегистрам(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок);
    КонецЕсли;

    Смотрим далее ДвиженияПоРегистрам() и видим:

    ДвиженияПоРегистрамУпр(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам,
    ТаблицаПоТоварамБезУслуг,Отказ, Заголовок);

    ДвиженияПоТоварамОрганизаций(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварамБезУслуг, Отказ, Заголовок);

    ДвиженияПоРегиструСписанныеТовары(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварамБезУслуг, Отказ, Заголовок);

    ДвиженияПоРегистрамРегл(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок);


    УчетнаяПолитика = РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата);

    Если УчетнаяПолитика.СписыватьПартииПриПроведенииДокументов Тогда

    // При списании партий также делаются записи в регистры бухгалтерского учета.
    Если ОтражатьВБухгалтерскомУчете Тогда
    Движения.Хозрасчетный.Записать();
    КонецЕсли;

    Если ОтражатьВНалоговомУчете Тогда
    Движения.Налоговый.Записать();
    КонецЕсли;

    ДвижениеПартийТоваров(Ссылка, Движения.СписанныеТовары.Выгрузить());

    Скромность украшает мужчину. Но настоящий мужчина в украшениях не нуждается.

  • Если ты имеешь ввиду
    В ответ на: // При списании партий также делаются записи в регистры бухгалтерского учета.
    Если ОтражатьВБухгалтерскомУчете Тогда
    Движения.Хозрасчетный.Записать();
    КонецЕсли;
    то там только одна проводка - сторно выручки (выгрузил значения в ТЗ и посмотрел). Все остальное - это вообще регистры.:хммм:

  • Смотрим к примеру на ДвиженияПоРегистрамРегл(). ТЧо мы там видим? А видим к примеру строчки типа

    ПроводкиБУ = Движения.Хозрасчетный;
    Проводка = ПроводкиБУ.Добавить();

    P.S. Их там много таких.. Все не приведешь.

    Скромность украшает мужчину. Но настоящий мужчина в украшениях не нуждается.

  • В том то и дело - что и в этом случае таже самая проводка "сторно". А где остальные я уже нашел.:улыб:Это ОбщийМодуль УправлениеЗапасамиПартионныйУчет. Процедуры НачислитьДоходОтРеализации и СписаниеНаСчет.
    Спасибо за участие:улыб:

  • Ну вот, а я собирался после очередного ответа запостить ссылку туда :). Такой облом.:улыб:

    Скромность украшает мужчину. Но настоящий мужчина в украшениях не нуждается.

Записей на странице:

Перейти в форум

Модератор: