Мобильная версия форумов
Открыть
 −8°C
завтра: −11°C
Погода в Перми
−8°C
ночью−10°C
утром−15°C
завтра−11°C
Подробно
 65,51
−0.0252
Курс USD ЦБ РФна 23 февраля
65,5149
−0.0252
 74,33
+0.0369
Курс EUR ЦБ РФна 23 февраля
74,3332
+0.0369
PRM.Форум /Компьютеры Интернет Связь / Программирование /

1с8.0. УПП. Как формируются проводки?

  • experienced

    Сообщений: 902

    В частности интересует формирование проводок документом "ОтчетККМОПродажах". Всю обработку проведения пошагово прошел, ничего кроме "Сторно выручки" не могу найти. Но ведь откуда-то они берутся...

  • experienced

    Сообщений: 637

    Чтот я тебя не понимаю.. Смотрим процедуру ОбработкаПроведения, видим:

    Если Не Отказ Тогда
    ДвиженияПоРегистрам(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок);
    КонецЕсли;

    Смотрим далее ДвиженияПоРегистрам() и видим:

    ДвиженияПоРегистрамУпр(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам,
    ТаблицаПоТоварамБезУслуг,Отказ, Заголовок);

    ДвиженияПоТоварамОрганизаций(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварамБезУслуг, Отказ, Заголовок);

    ДвиженияПоРегиструСписанныеТовары(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварамБезУслуг, Отказ, Заголовок);

    ДвиженияПоРегистрамРегл(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, Отказ, Заголовок);


    УчетнаяПолитика = РегистрыСведений.УчетнаяПолитика.ПолучитьПоследнее(Дата);

    Если УчетнаяПолитика.СписыватьПартииПриПроведенииДокументов Тогда

    // При списании партий также делаются записи в регистры бухгалтерского учета.
    Если ОтражатьВБухгалтерскомУчете Тогда
    Движения.Хозрасчетный.Записать();
    КонецЕсли;

    Если ОтражатьВНалоговомУчете Тогда
    Движения.Налоговый.Записать();
    КонецЕсли;

    ДвижениеПартийТоваров(Ссылка, Движения.СписанныеТовары.Выгрузить());

    Скромность украшает мужчину. Но настоящий мужчина в украшениях не нуждается.

  • experienced

    Сообщений: 902

    Если ты имеешь ввиду
    В ответ на: // При списании партий также делаются записи в регистры бухгалтерского учета.
    Если ОтражатьВБухгалтерскомУчете Тогда
    Движения.Хозрасчетный.Записать();
    КонецЕсли;
    то там только одна проводка - сторно выручки (выгрузил значения в ТЗ и посмотрел). Все остальное - это вообще регистры.:хммм:

  • experienced

    Сообщений: 637

    Смотрим к примеру на ДвиженияПоРегистрамРегл(). ТЧо мы там видим? А видим к примеру строчки типа

    ПроводкиБУ = Движения.Хозрасчетный;
    Проводка = ПроводкиБУ.Добавить();

    P.S. Их там много таких.. Все не приведешь.

    Скромность украшает мужчину. Но настоящий мужчина в украшениях не нуждается.

  • experienced

    Сообщений: 902

    В том то и дело - что и в этом случае таже самая проводка "сторно". А где остальные я уже нашел.:улыб:Это ОбщийМодуль УправлениеЗапасамиПартионныйУчет. Процедуры НачислитьДоходОтРеализации и СписаниеНаСчет.
    Спасибо за участие:улыб:

  • experienced

    Сообщений: 637

    Ну вот, а я собирался после очередного ответа запостить ссылку туда :). Такой облом.:улыб:

    Скромность украшает мужчину. Но настоящий мужчина в украшениях не нуждается.

Записей на странице:

Перейти в форум

Модератор: