20°C
завтра: 24°C
Погода в Перми
20°C
вечером25°C
ночью16°C
завтра24°C
Подробно
 63,13
+0.1514
Курс USD ЦБ РФна 24 июля
63,1290
+0.1514
 70,64
−0.0196
Курс EUR ЦБ РФна 24 июля
70,6350
−0.0196
PRM.Форум /Компьютеры Интернет Связь / Программирование /

1c у части доков не видно проводок.

  • Вчера столкнулся
    Конфа - обычная комплексная.
    Период август месяц
    Журнал общий
    Доки реализация - в панели активна кнопка DK
    этот же период
    Поступления ТМЦ - кнопка не активна - но заходишь в док - кнопка доп -глянуть бух движения - проводки есть
    проводится нормально.
    но кнопка неактивная.
    В чем глюк?

    Quod principi placuit, legis habet vigorem

  • Я в ПУБЕ не нашел документа с видом или синонимом поступление ТМЦ, для всех видов поступлений в ПУБЕ установлен флаг "Бухгалтерский учет", и создавать операцию "Всегда". Поэтому я думаю у тебя есть свой собственный документ, который не имеет операции. Поэтому тебе и не видно проводок. А то что ты видешь через отчет бух движения , так это только отчет по проводкам, на основании движений документа по регистрам.

  • А в предыдущих периодах есть проводки на поступление ТМЦ?

    Осторожнее с травой!
    Если хапнешь много дряни
    Увезут тебя с собой
    Злые инопланетяне

  • да
    до июля все верно.
    вот ведь ццуко какое

    Quod principi placuit, legis habet vigorem

  • в шаблоны проводок не смотрел?
    мож кто шаблон проводки по поступлению ТМЦ удалил?

    Осторожнее с травой!
    Если хапнешь много дряни
    Увезут тебя с собой
    Злые инопланетяне

  • да есть шаблоны
    все нормально
    июль провожу - все зашибись
    август - фиг
    если проводка явно прописана (не шаблон) то все нормально
    к примеру
    если клиент = "Пупкин" тогда
    Дт 41 кр 50
    иначе
    глПриПроведении(Контекст, ВидыДвижений);
    конецесли
    притом такая фигня для любого дока

    Quod principi placuit, legis habet vigorem

  • Процедура глПриПроведении(Конт, ВидыДвижений="") Экспорт
    Конт.ЮрЛицо = Конт.Фирма.ЮрЛицо;
    Если Метаданные.Документ(Конт.Вид()).БухгалтерскийУчет = 1 Тогда
    Если (ПустаяСтрока(ВидыДвижений) = 1) ИЛИ (Найти(ВидыДвижений, "Операция") 0) Тогда
    Конт.ОчиститьДвижения("Операция"); ФормированиеПроводок = Конт.Фирма.ЮрЛицо.ФормированиеПроводок.Получить(Конт.ДатаДок);
    Если ФормированиеПроводок = Перечисление.ФормированиеПроводок.ПоДокументам Тогда ТаблицаПроводок = глПолучитьТаблицуПроводок(Конт.ТекущийДокумент());

    глЗаполнитьОперациюПроводками(Конт.Операция, ТаблицаПроводок); ХозОперация = глПолучитьХозОперацию(СоздатьОбъект("СписокЗначений"), Конт.ТекущийДокумент(), Конт.Вид());
    Конт.Операция.Содержание = ХозОперация.Наименование;

    Попытка
    Конт.Операция.Записать();
    Исключение
    глНеПроводить(Конт, ОписаниеОшибки());
    КонецПопытки;

    КонецЕсли;
    КонецЕсли;
    КонецЕсли;

    // Покажем трассировку, если она есть
    НазваниеТрассировки = "Проведение документа "+Конт.ПредставлениеВида()+" № "+Конт.НомерДок +" от "+Конт.ДатаДок;
    Если ТипЗначенияСтр(глСообщенияТрассировки) = "СписокЗначений" Тогда
    Если НазваниеТрассировки = СокрЛП(глСообщенияТрассировки.ПолучитьЗначение(3)) Тогда
    глПоказатьТрассировку(глСообщенияТрассировки);
    глСообщенияТрассировки = 0;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры // глПриПроведении()


    бухитоги, периоды все открыто
    но вот в июле все нормально - а дальше фиг.
    уже и сентябрем делал - не катит

    Quod principi placuit, legis habet vigorem

  • глЗаполнитьОперациюПроводками()
    отладчиком пошагово прогони

    Осторожнее с травой!
    Если хапнешь много дряни
    Увезут тебя с собой
    Злые инопланетяне

  • нифига
    ФормированиеПроводок = Конт.Фирма.ЮрЛицо.ФормированиеПроводок.Получить(Конт.ДатаДок);
    вот эта строчка не работала
    Конт.ДатаДок = пусто было
    а в июле 'по документам'
    вообщем загнал другую строку
    ФормированиеПроводок = Конт.Фирма.ЮрЛицо.ФормированиеПроводок.Получить('01.07.2006');
    все заработало

    бухгалтер молчит на вопрос чего меняла. :безум:

    Quod principi placuit, legis habet vigorem

  • Смотри историю значения ФормированиеПроводок.
    Там по-видимому она и порылась...

    "России нужны не проповеди, а пробуждение в народе чувства человеческого достоинства"
    (с) В.Г.Белинский

Записей на странице:

Перейти в форум

Модератор: