10°C
завтра: 13°C
Погода в Перми
10°C
утром5°C
днем13°C
завтра13°C
Подробно
 64,43
−0.1988
Курс USD ЦБ РФна 15 июня
64,4326
−0.1988
 72,70
−0.3148
Курс EUR ЦБ РФна 15 июня
72,6993
−0.3148
  • Вот кусок кода:
    Процедура Расчет(Спр,НДата,КДата)
    <...>
    Пока НДата <= КДата Цикл
    <...>
    НДата=НДата+1;
    КонецЦикла;
    КонецПроцедуры
    Процедура ЧтоНадо()
    <...>
    НачДата = //какая-то дата
    КонДата = НачДата + Интервал;
    Расчет(СпрНом,НачДата,КонДата);
    //что такое ? кто это сделал ?:улыб:
    КонецПроцедуры

    И собственно вопрос.
    Почему после завершения выполнения процедуры Расчет переменная НачДата имеет значение, отличное от того, что было до вызова Расчета ??? :eek:
    Я же делаю инкремент переменной НДата, а не НачДата, почему увеличивается и НачДата ??

  • по умолчанию переменные в 1С передаются по ссылке
    если в объявлении заголовка процедуры/функции не задано ключевое слово Знач

    Осторожнее с травой!
    Если хапнешь много дряни
    Увезут тебя с собой
    Злые инопланетяне

  • например если бы было объявлено так:
    Процедура Расчет(Спр,НДата Знач,КДата Знач)
    то после выполнения функции значения НДата и КДата не поменялись бы

    Осторожнее с травой!
    Если хапнешь много дряни
    Увезут тебя с собой
    Злые инопланетяне

  • спасибо

  • up
    на работе 1С Предприятие 7.7 (Корп. финансы+Бухучёт)
    Возможно каким то образом сформировать отчёт по дате внесения документа в программу?

  • Если нужна дата фактического создания, то надо копать журнал регистрации.
    По отдельным объектам(документам и тп) можно посмотреть через Монитор.
    Для множественного выбора в принципе возможно через самописный отчет, который будет разбирать файл журнала.

    зы.
    Но журнал регистрации вещь второстепенная и может быть изменен и просто удален без последствий для целостности данных. Плюс пытливый ум может сделать изменения в базе без фиксации в журнале...

    "России нужны не проповеди, а пробуждение в народе чувства человеческого достоинства"
    (с) В.Г.Белинский

  • грубо говоря, у меня периодически возникает необходимость увидеть в течении незакрытого периода какие документы внесены задним числом, сранить дату документа и дату внесения с 1С
    получается в 7.7 штатно это не реализовано :хммм:

  • Штатно это реализовано через "монитор пользователей" - "журнал регистрации". Для Вашего случая надо отобрать по видам событий документов "... задним числом" :спок:

    Ещё есть полезная тулза "СМИТ Сверка баз (компаратор)", которая позволяет сверить архивную и рабочую базы на изменения в документах; показывает в какой строке (или в шапке), какой реквизит изменили (было/стало). :bday:
    Можно найти на сайте из моего профиля.

    NSK & SIB

  • Если Вы уверены в целостности журнала то да, и более того, видел на инфостарте готовые подобные отчеты.
    Но как уже отмечалось выше, пытливый ум может менять документы и справочники без записей в журнале. Например обработкой универсального подбора UChoice.

    Осторожнее с травой!
    Если хапнешь много дряни
    Увезут тебя с собой
    Злые инопланетяне

  • а по поводу внесения задним числом - в опер. учете есть замечательная штука - граница последовательности. сразу видно вносилось задним числом или нет.

    Осторожнее с травой!
    Если хапнешь много дряни
    Увезут тебя с собой
    Злые инопланетяне

Записей на странице:

Перейти в форум

Модератор: