8°C
завтра: 7°C
Погода в Перми
8°C
вечером9°C
ночью3°C
завтра7°C
Подробно
 63,79
−0.1742
Курс USD ЦБ РФна 23 апреля
63,7860
−0.1742
 71,72
−0.2022
Курс EUR ЦБ РФна 23 апреля
71,7210
−0.2022
PRM.Форум /Компьютеры Интернет Связь / Программирование /

В Excel найти значение одной ячеки в другой...

  • member

    Сообщений: 29

    Есть один столбец, ну ооочень большой, с текстовыми данными. Хочу найти в этом столбце несколько важных для меня слов. Во втором столбце в первой ячейке пишу формулу:
    =ЕСЛИ(ЕОШИБКА(НАЙТИ("Нужное слово";A4;1));"Нет нужного слова";"Нужное слово")
    Далее распространяю эту формулу на весь столбец B (тяну ооочень долго, потому, как столбец ооочень большой).
    Одно слово нашел.
    Теперь хочу найти второе нужное слово в том же столбце текстовых данных.
    Либо повторяю тоже самое со столбцом B, исправляя "Нужное слово" на "Второе нужное слово" - пишу новую формулу
    =ЕСЛИ(ЕОШИБКА(НАЙТИ("Второе нужное слово";A4;1));"Нет нужного слова";"Второе нужное слово")
    , либо с помощью команды "Заменить" во всем втором столбце меняю "Нужное слово" на "Второе нужное слово".

    Вопрос. Как сделать так, чтобы можно было брать значение какой то ячейки и искать в нужном столбце именно это значение? Т.е. если мне нужно найти второе нужное слово, то я его ввожу в какую то одну ячейку, формулы автоматом (или по нажатии клавиши) пересчитываются и результат на лицо.

    СофтоПарк.Ру Место встречи с необходимым!

  • v.i.p.

    Сообщений: 13508

    =ЕСЛИ(ЕОШИБКА(НАЙТИ($A$1;A4;1));"Нет нужного слова";"Нужное слово")
    В ячейке А1 пишем слово, для поиска

  • member

    Сообщений: 29

    Уп-с...
    Я однажды попробовал такой вариант у меня ничего не получилось. Решил, что такой вариант не проканывает.
    Сегодня решил еще раз проверить. Получилось.
    Теперь вот сижу и чешу репу, чего же я тогда (прошлый раз) мог не правильно сделать?...
    Пришло на ум только то, что ставил ковычки.
    Вот балбес!
    Спасибо большое за помощь!

    СофтоПарк.Ру Место встречи с необходимым!

  • v.i.p.

    Сообщений: 13508

    Всегда пожалуйста

Записей на странице:

Перейти в форум

Модератор: